目次

目次

従来のダッシュボードグラフ

従来のダッシュボードグラフ

従来のダッシュボードグラフの概要

次のセクションでは、ダッシュボードツールのさまざまなチャートとグラフで使用できる各種タブについて説明します。

[関連付け]タブ

カスタムチャートに関連付けを追加する複数の方法があります。

  • ツリー参照ダイアログ - ツリー参照ダイアログの詳細については、ツリー参照ダイアログページを参照してください。
  • グローバル変数/テーブル - グローバル変数とグローバルテーブルのリストは、モデルで使用可能なものに基づいて入力されます。グローバル変数のリストには、整数と倍精度浮動小数点数のタイプのみが含まれます。
  • サンプラー - モデルのオブジェクトをサンプリングします。
  • オブジェクト選択ウィンドウ - 現在のモードは、参照しているウィンドウの上部に強調表示されます。
  • クラス別に参照 - このオブジェクト追加方法では、オブジェクトがクラス別に並べ替えられます。クラス全体を選択するには、タイプアイコンをクリックします。オブジェクトをクリックして選択または選択解除します。
  • グループ別に参照 - このオブジェクト追加方法では、オブジェクトがグループ別に並べ替えられます。グループ全体を選択するには、タイプアイコンをクリックします。オブジェクトをクリックして選択または選択解除します。
  • オブジェクト別に参照 - このオブジェクト追加方法では、モデルのすべてのオブジェクトが一覧表示されます。オブジェクトをクリックして選択または選択解除します。
  • ドラッグで選択 - このオブジェクト追加方法では、3Dモデルビューが使用されます。現在のウィンドウからモデル内の追加するオブジェクトにターゲットアイコンをドラッグします。

[関連付け]タブには、次のプロパティがあります。

関連付けの対象は、モデル内のオブジェクト、ノード、変数です。

アイコン 説明
現在の関連付けのリストに関連付けを追加します。
選択した関連付けをリストから削除します。
選択した関連付けをリストの上または下に移動します。
モデル内のノードまたはオブジェクトをサンプリングします。

表示名

グループを使用するときに表示名が指定されていない場合、グループメンバーに表示されるタイトルはモデル内のパスになります。

[色]タブ

[色]ページでは、グラフの色を定義できます。使用可能なオプションは、グラフによって異なります。状態チャートの場合は、状態ごとに色を設定します。上の画像では2つの色が表示されています。左側の色は、その状態の通常の色です。右側の色は、[利用分析]タブで[半透明として黄色のチェックされた状態を表示]チェックボックスがオンになっている場合に使用される半透明の色です。統計グラフ(平均コンテンツなど)では、統計ごとにこれらの色が対応します。折れ線グラフは、オブジェクトまたはグループごとに色を定義します。ガントチャートは、状態またはオブジェクトの色を表示します。

テキストグラフでは色を使用できません。

アイコン 説明
保存された色スキームをロードし、ツリー内の色スキームを編集できます。
現在の色スキームを保存します。
色パレットを表示します。
FlexSimまたはFlexSimの外部で色をサンプリングできます。

色を定義

このチェックボックスをオンして、カスタムの色のセットを定義します。

アイテムトレースガントとカスタムチャート

アイテムトレースガントチャートとカスタムチャートでは、凡例またはシリーズがグラフに動的に追加されるため、を使用して色を追加、削除できます。

[データ]タブ

[データ]タブは、カスタムチャートとカスタムガントチャートで使用されます。[データ]タブには、チャートに表示されるデータをカスタマイズできる複数のピックリストがあります。次のプロパティがあります。

プリセットを適用

このボタンには、カスタムチャートまたはカスタムガントチャートの使用を開始するためのプリセットのリストが含まれています。プリセットには、テーブル、バンドルなどの値にアクセスするためのコードが含まれています。

[一般]タブ

ダッシュボードグラフの[一般]ページは、統計オブジェクトと表示タイプによって異なります。

折れ線グラフ

折れ線グラフには、次の一般的なプロパティがあります。

  • 表示タイプ - グラフの表示スタイルを変更します。
  • 積み重ね棒グラフ - 棒グラフのみ。1つのオブジェクトのデータの各セグメントを1つの棒に積み重ねます。
  • 凡例を表示 - グラフに凡例を追加します。
  • 精度 - グラフテキストの数値の精度を定義します。折れ線グラフでは使用できません。
  • フォントサイズ - グラフテキストのフォントサイズを定義します。
  • 棒サイズ - 棒グラフのみ。棒グラフの棒の高さを定義します。
  • 定義された時間間隔のデータのみ収集 - このグラフの統計情報が記録される期間を作成します。
  • 開始時間 - 統計情報の記録を開始するタイミングを定義します。
  • 終了時間 - 統計情報の記録をやめるタイミングを定義します。
  • 間隔 - 折れ線グラフの更新頻度を定義します。
  • 時間スケール - X軸に沿って数字を表示する時間スケールを定義します。
  • Y軸タイトル - Y軸に沿って表示されるテキスト。
  • X軸タイトル - X軸に沿って表示されるテキスト。

状態統計グラフ

状態統計グラフには、次の一般的なプロパティがあります。

  • 表示タイプ - グラフの表示スタイルを変更します。
  • 現在の状態のみを表示 - 値のテーブルチャートでのみ使用できます。オブジェクトの現在の状態名を表示します。
  • 1つの円にすべて結合 - すべての円グラフを1つの円グラフに結合します。すべてのオブジェクトの値を平均します。
  • 割合の代わりに合計を表示 - 表示された値を割合から合計に変更します。
  • 凡例を表示 - グラフに凡例を追加します。
  • 精度 - グラフテキストの数値の精度を定義します。
  • フォントサイズ - グラフテキストのフォントサイズを定義します。
  • 棒サイズ - 棒グラフのみ。棒グラフの棒の高さを定義します。
  • 定義された時間間隔のデータのみ収集 - このグラフの統計情報が記録される期間を作成します。
  • 開始時間 - 統計情報の記録を開始するタイミングを定義します。
  • 終了時間 - 統計情報の記録をやめるタイミングを定義します。

処理後のフィルタリング

処理後のフィルタリングの全体の状態履歴を収集]オプションがオンになっている場合、FlexSimは、グラフ内のすべてのオブジェクトについて各状態の変更が発生した時期を記録します。モデルを実行した後、[時間でフィルタリング]オプションをオンにし、[から]フィールドと[まで]フィールドに時間間隔を入力できます。[適用]または[更新]をクリックすると、その時間間隔の状態データがグラフに表示されます。モデルをリセットすると、[時間でフィルタリング]オプションはオフになります。

ガントチャート

ガントチャートには、次の一般的なプロパティがあります。

  • 表示タイプ - グラフの表示タイプを変更します。これは、[状態]または[アイテムトレース]のいずれかになります。
  • 凡例を表示 - グラフに凡例を追加します。
  • フォントサイズ - グラフテキストのフォントサイズを定義します。
  • 棒サイズ - 棒の高さを定義します。
  • 定義された時間間隔のデータのみ収集 - このグラフの統計情報が記録される期間を作成します。
  • 間隔タイプ - チャートによっては、ガントチャートのような間隔タイプを指定するオプションが追加される場合があります。間隔タイプは次のように設定できます。
    • 時間単位 - x軸が指定した時間単位に調整されます。[時間単位]を[日付に基づく]に設定すると、y軸には日付が表示され、x軸には各日の時刻が表示されます。[ラップ]は、[日付に基づく]を使用すると、自動で[毎週]に設定されます。
    • ラップ - このチェックボックスをオンにすると、チャートは指定した期間ごとにデータをラップします。これにより、グラフは垂直方向に拡大します。
    • すべてをラップ - [ラップ]チェックボックスがオンになっている場合、グラフをラップする時間を定義します。
      • 絶対時間:絶対時間:[開始時間]にデータ収集を開始し、[終了時間]にデータ収集を終了します。
      • 時間ウィンドウ:指定された期間にわたってデータを収集します。[長さ]フィールドは、最初に記録された統計から最後に記録された統計までの時間を定義し、モデルを実行すると動的に更新されます。データがモデル実行で収集されると、チャートのすべてのデータを指定した時間内に保持するために、最初のデータは削除されます。
  • 開始時間 - 統計情報の記録を開始するタイミングを定義します。
  • 終了時間 - 統計情報の記録をやめるタイミングを定義します。
  • X軸タイトル - X軸に沿って表示されるテキスト。

追跡変数グラフ

追跡変数グラフには、次の一般的なプロパティがあります。

  • 表示タイプ - グラフの表示スタイルを変更します。
  • 凡例を表示 - グラフに凡例を追加します。
  • 値を正規化 - 実際の値ではなく、ヒストグラムの値をパーセントで表示します。
  • バーの数 - ヒストグラムのバーの数を調整します。

[アイテムトレース]タブ

[アイテムトレース]タブには、次のプロパティがあります。

トレース要件

このピックリストでは、トレースするフローアイテムを定義できます。

  • 現在:[オブジェクト]ページで定義されているオブジェクト。
  • アイテム:関連するフローアイテム。

アイテム名

このピックリストでは、トレースされたアイテムのカスタム表示名を定義できます。

  • 現在:[オブジェクト]ページで定義されているオブジェクト。
  • アイテム:関連するフローアイテム。
  • itemnode:アイテムに関連付けられたノードとそのグラフデータ。このノードの名前を設定すると、グラフの表示名が設定されます。

[オブジェクト]タブ

このグラフにオブジェクトを追加するには、5つの方法があります。

  1. クラス別に参照 - このオブジェクト追加方法では、オブジェクトがクラス別に並べ替えられます。クラス全体を選択するには、タイプアイコンをクリックします。オブジェクトをクリックして選択または選択解除します。
  2. グループ別に参照 - このオブジェクト追加方法では、オブジェクトがグループ別に並べ替えられます。グループ全体を選択するには、タイプアイコンをクリックします。オブジェクトをクリックして選択または選択解除します。

  3. オブジェクト別に参照 - このオブジェクト追加方法では、モデルのすべてのオブジェクトが一覧表示されます。オブジェクトをクリックして選択または選択解除します。

  4. ドラッグで選択 - このオブジェクト追加方法では、3Dモデルビューが使用されます。現在のウィンドウからモデル内の追加するオブジェクトにターゲットアイコンをドラッグします。

[オブジェクト]タブには、次のプロパティがあります。

アイコン 説明
現在のオブジェクトのリストにオブジェクトまたはグループを追加します。
現在のオブジェクトのリストからオブジェクトを削除します。
選択したオブジェクトをリストの上に移動します
選択したオブジェクトをリストの下に移動します
モデル内のオブジェクトをサンプリングします。
複数のオブジェクトを1つのオブジェクトに結合します。
結合したオブジェクトを各コンポーネントに分割します。

表示名

グラフに表示されるオブジェクトまたはグループの名前を定義します。このフィールドを空白のままにすると、オブジェクト名またはグループ名が表示されます。

状態プロファイル

状態統計のみ。使用する状態プロファイルを定義します。このオプションは、オブジェクトリスト内の最初のオブジェクトに追加の状態プロファイルがある場合にのみ使用できます。リスト内のすべてのオブジェクトは、状態プロファイルが選択されている必要があります。

トレースを開始

ガントチャート(アイテムトレース)のみ。アイテムトレースを開始する時期を指定します。この値は個々のオブジェクトごとに設定できます。

[統計]タブ

[統計]タブには、次のプロパティがあります。

アイコン 説明
現在の統計のリストに統計を追加します。
現在の統計リストから統計を削除します。
選択した統計をリストの上に移動します。
選択した統計をリストの下に移動します。

利用可能な統計

次の統計情報を使用できます。

  • 出力/ - 時間あたりの出力を測定します。時間の単位はサイドリストから選択できます。
  • 入力/ - 時間あたりの入力を測定します。時間の単位はサイドリストから選択できます。
  • 時間あたりの移動距離 - オブジェクトの速度を測定します。長さと時間の単位はサイドリストから選択できます。
  • 移動した距離合計 - オブジェクトが移動した合計距離を測定します。長さの単位はサイドリストから選択できます。
  • カスタム - カスタムコードを実行して、表示される値を定義できます。

[追跡変数]タブ

[追跡変数]タブには、次のプロパティがあります。

アイコン 説明
現在の追跡変数のリストに追跡変数を追加します。
現在の追跡変数のリストから追跡変数を削除します。
選択した追跡変数をリストの上または下に移動します。

[利用分析]タブ

[利用分析]タブには、次のプロパティがあります。

チェックした状態をすべて表示

すべての状態を単色で表示します。オブジェクトが利用された時間の割合は計算されません。

緑色にチェックされた状態のみを表示

オブジェクトが緑色のチェックされた状態になっている時間の割合を表示します。他の状態情報は表示しません。

半透明として黄色のチェックされた状態を表示

緑色のチェックされた状態を緑色のみで表示します。黄色のチェックされた状態は半透明の色で表示されます。

追加ボタン

手動で状態をリストに追加します。状態によっては自動で状態リストに表示されない場合があります。これは、一連の「使用済み」状態を持つオブジェクトには、setstate()コマンドやstopobject()コマンド、タイムテーブルやMTBF/MTTRツールを使用して手動で設定された状態が含まれていない可能性があるためです。右クリックメニューを使用して、手動で追加した状態をリストから削除します。

状態リスト

選択したオブジェクトの有効な状態がこのリストに表示されます。チェックマークをクリックすると、3つの計算オプションが切り替わります。