目次

目次

ツールボックスを使用する

ツールボックスを使用する

ツールボックスの概要

ツールボックスでは、FlexSimのほぼすべてのツールにアクセスできます(ツールボックスで利用可能なすべてのツールの簡単な説明については、「ツールの概要」を参照してください)。

ツールボックスでは、シミュレーションモデルで使用しているすべてのツールとツールコンポーネントを確認できます。また、ツールボックスを使用してツールコンポーネントを管理することもできます(詳細については、「ツールコンポーネントとは」を参照してください)。

ツールボックスは、シミュレーションモデルを構築するときにさまざまタスクの作業で使用するため、その仕組みに慣れ親しんでください。

ツールの概要

次の表に、ツールボックスで使用できる主なツールを[ツール]メニューに表示される順で示します。

ツール 説明
グローバルテーブル FlexSimの他のツールで動的に参照できる情報をインポートおよび保存できる内部スプレッドシート。詳細については、「グローバルテーブル」を参照してください。
タイムテーブル モデル内の特定の3Dオブジェクトに対して予定されたダウン時間などの状態変更をスケジュールします。詳細については、「タイムテーブル」を参照してください。
MTBF MTTR モデル内の3Dオブジェクトグループにランダムな故障時間と復旧時間を設定します。詳細については、「MTBF MTTR」を参照してください。
ダッシュボード シミュレーションの実行からデータをリアルタイムで表示します。詳細については、「ダッシュボードとチャートについての主要な概念」を参照してください。
処理フロー モデルの全体的なロジックを構築します。詳細については、「処理フローインターフェイスの概要」を参照してください。
グローバルリスト 3Dオブジェクト間でより複雑なフローを作成する必要がある場合に使用します。リストは、コネクションレスルーティング、フローアイテムのフィルタリング、タスク管理、固定リソースの優先順位付けにも使用できます。詳細については、「リストについての主要な概念」を参照してください。
統計コレクター シミュレーションモデルから標準またはカスタム統計を取得するために使用されます。詳細については、「統計コレクターを使用する」を参照してください。
フローアイテムビン シミュレーションモデル内のフローアイテムの外観をカスタマイズします。詳細については、「フローアイテムビンを使用する」を参照してください。

ツールコンポーネントとは

このユーザーマニュアルでは、特定のツールで使用される基本エンティティを説明する際に、一般的な意味でツールコンポーネントという用語を使用します。

たとえば、処理フローツールを使用してモデルのロジックを作成できます。処理フローツールを使用すると、それぞれ独自のモデルロジックを含むさまざまな処理フローを作成できます。個々の処理フローが、処理フローツールのツールコンポーネントになります。

ダッシュボードツールは別の例です。ダッシュボードツールを使用すると、シミュレーションモデルの実行中にチャートや統計を表示できます。複数のダッシュボードを作成して、これらの統計を表示できます。個々のダッシュボードが、ダッシュボードツールのツールコンポーネントになります。

次の画像に、ツールボックスにさまざまなツールコンポーネントが含まれる処理フローツールとダッシュボードツールの両方の例を示します。

このトピックの他のセクションでは、ツールボックスでツールコンポーネントを管理する方法について説明します。

新しいツールコンポーネントを追加する

これまでに特定の種類のツールコンポーネントをシミュレーションモデルに追加したかどうかによって、新しいツールコンポーネントを追加する方法が少し異なります。

新しいツールコンポーネントを初めて追加する場合は:

  1. ツールボックスを開いた状態で、ツールボックスの上部にある[追加]ボタン をクリックします。利用可能なツールのメニューが開きます。
  2. 追加する新しいツールコンポーネントのツールの名前を選択します。たとえば、新しい処理フローを追加する場合はメニューから[処理フロー]を選択し、新しいダッシュボードを追加する場合はメニューから[ダッシュボード]を選択します。

これにより、新しいコンポーネントが作成されます。新しく作成されたコンポーネントは、該当するツールで自動で開きます。このツールウィンドウの表示オプションを変更する方法については、「ウィンドウとタブを並べ替える」を参照してください。

ツールボックスにその他のツールコンポーネントを追加するには:

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. ツール名を右クリックします。メニューから[[ツールコンポーネント]を追加]を選択します。たとえば、新しい患者のトラックを追加する場合は、[ダッシュボード]を右クリックし、メニューから[ダッシュボードを追加]を選択します。新しく作成されたコンポーネントは、該当するツールですぐに開かれます。

ツールコンポーネントを開く/閉じる

必要なツールコンポーネントがまだ開いていない場合は、ツールボックスを使用して開くことができます。(ツールコンポーネントの詳細については、「ツールコンポーネントとは」を参照してください)。

ツールコンポーネントを開くには:

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. 開くツールコンポーネントをリストでダブルクリックします。選択した特定のツールコンポーネントとともに該当するツールが開きます。

ツールコンポーネントを閉じるには、ツールの右上隅にある X をクリックします。

ツールコンポーネントの名前を変更する

ツールコンポーネントの名前を変更するには:

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. 名前を変更するツールコンポーネントを右クリックします。メニューから[名前を変更]を選択します。
  3. ツールコンポーネントの新しい名前を入力し、Enterキーを押します。これで、ツールコンポーネントに異なる名前が付きました。

ツールコンポーネントをコピーする

わずかに異なる非常に似た2つのコンポーネントを作成する場合は、ツールコンポーネントをコピーすると便利です。たとえば、2つの処理フローを同じ5つのアクティビティで開始する場合は、最初の処理フローのコピーを作成し、そのコピーを使用して2番目の処理フローを作成し、時間を節約できます。

ツールコンポーネントのコピーを作成するには:

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. コピーするツールコンポーネントを右クリックします。メニューから[重複]を選択します。

デフォルトでは、新しいコンポーネントは最初にコピーしたコンポーネントの名前を使用しますが、ProcessFlow_2など、名前の末尾に_2が付きます。コンポーネントの名前を変更する方法の詳細については、「ツールコンポーネントの名前を変更する」を参照してください。

ツールコンポーネントを再編成する

コンポーネントが[ツールボックス]に表示される順序を変更するには、次の手順を実行します。

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. 再編成するコンポーネントを右クリックし、選択したコンポーネントの移動方法に応じて、次のいずれかのオプションを選択します。
    • 上に移動 - 選択したコンポーネントをリストの1つ上の位置に移動します。
    • 下に移動 - 選択したコンポーネントをリストの1つ下の位置に移動します。
    • 一番上に移動 - 選択したコンポーネントをリストの最初の位置に移動します。
    • 一番下に移動 - 選択したコンポーネントをリストの最後の位置に移動します。

ツールコンポーネントを削除する

ツールコンポーネントを削除するには、次の手順を実行します。

  1. 必要に応じて、該当するツール名の横にあるプラス記号 をクリックして、それまでに作成されたツールコンポーネントのリストを展開して表示します。
  2. 削除するツールコンポーネントを右クリックし、メニューから[削除]を選択します。